package.json 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. {
  2. "name": "intimacy",
  3. "version": "0.1.0",
  4. "private": true,
  5. "scripts": {
  6. "serve": "vue-cli-service serve",
  7. "build": "vue-cli-service build",
  8. "lint": "vue-cli-service lint"
  9. },
  10. "dependencies": {
  11. "core-js": "^3.3.2",
  12. "pug": "^2.0.4",
  13. "tone": "^13.8.25",
  14. "vue": "^2.6.10",
  15. "vue-markdown-v2": "^0.1.7",
  16. "watchify": "^3.11.1"
  17. },
  18. "devDependencies": {
  19. "@vue/cli-plugin-babel": "^4.0.0",
  20. "@vue/cli-plugin-eslint": "^4.0.0",
  21. "@vue/cli-service": "^4.0.0",
  22. "babel-eslint": "^10.0.3",
  23. "eslint": "^5.16.0",
  24. "eslint-plugin-vue": "^5.0.0",
  25. "raw-loader": "^3.1.0",
  26. "vue-template-compiler": "^2.6.10"
  27. },
  28. "eslintConfig": {
  29. "root": true,
  30. "env": {
  31. "node": true
  32. },
  33. "extends": [
  34. "plugin:vue/essential",
  35. "eslint:recommended"
  36. ],
  37. "rules": {
  38. "no-console": 0
  39. },
  40. "parserOptions": {
  41. "parser": "babel-eslint"
  42. }
  43. },
  44. "postcss": {
  45. "plugins": {
  46. "autoprefixer": {}
  47. }
  48. },
  49. "browserslist": [
  50. "> 1%",
  51. "last 2 versions"
  52. ]
  53. }